Back to overview

Temporary downtime

Feb 2, 2023 at 9:29am UTC

Resolved
Feb 2, 2023 at 9:29am UTC

Due to a network issue, partial downtime is observed at the moment.
Issue has been fixed at 09:30am (Lisbon)